User avatar
By aaronsummers
#100366
APEXI SAFC/NEO B16 INSTALL AND SETTINGS

Image

I had to extend my wires to reach the ECU so if you do make sure you keep track of which wire is which.

There is a spot in the firewall behind the stock air box that you can run the wires into the cabin. I took a screw driver and poked a hole in the grommet and fed the wires through. I taped all my wires together to give it a cleaner look but that is not necessary.
Image

After you get all the wires to the ECU unplug the negative post of your battery. If you have a stock intake you will need to remove the snorkel, if you have an Injen intake you will need to remove the 90 degree bend pipe from the upper hard pipe and the lower hard pipe and set it aside.

Next there is a plastic box that keeps all the wires for the ECU all nice and neat that can be removed to make your life easier.
Image

Now unplug the ECU there are three connectors. To remove the connector lift the grey clip up until it clicks then just pull the plug out of the ECU. Strip the tape off the wires. There is a piece of shielding on the top two plugs that you can reuse so don’t throw it away.

The wiring diagram is looking at the harness side of the plug, so you need to look at where the wires go into the plug. Follow the diagram, if you get to a wire that is the wrong color then stop and check it all just to be sure you haven’t missed anything. I recommend soldering the wires onto the ECU harness not using wire taps, but it is really preference. This is my modified wiring diagram.
Image
Image

Once you have the neo wired up to the ECU make sure everything is taped up good so nothing can short out and plug the ECU back up and reconnect the battery.

DO NOT START your car yet, just turn your ignition to the ON position and let the neo come on. Now would be a good time to look at the wiring at the ECU and make sure there is no smoke or a burning smell, if there is cut the car off quickly and check your wiring(remember to disconnect your battery before unplugging the ECU).

From the main menu select etc. and initialize, select yes to initialize all (this clears any old tune or settings that may be stored in the neo).
Image
Image
Image

Now go to Car Select from the etc. menu and put CYL on 1 and make sure the arrow is pointing up. After this you will do a throttle learn for the neo MAKE SURE YOUR CAR IS IN FIRST GEAR as the neo will not read voltage of the pedal if it is not in gear.
Image
Image
Image

Next select Sensor Select from the etc. menu and select Hot Wire, settings for this should be 1&1 or 24&24 then leave single and single.
Image
Image
Image

That is all the setup for the car, there are some display settings you can look at and change later if you want. Turn the ignition off and then start the car. If everything looks ok then you are good to go.
Image

Note that I did get a CEL P0603 which is Internal Control Module Keep Alive Memory (KAM) after the install. I cleared the code and it has not come back, maybe something to do with having the ECU unplugged.

I highly recommend not trying to tune your car without a wideband so you can monitor your air fuels, with that said I would recommend a wideband that does datalogging; it will make it easier to tune the car.

My personal pick of widebands is Zeitronix.

That is all i have right now, i will get more pics of the wiring the neo up this weekend when i break it all back down to clean everything up.

If there is anything that is not clarified or needs more work on explaining let me know and ill add it to this post. Also if anyone is haveing any problems with a install feel free to PM me or create a new thread on the matter.


All this info came from people on this site. I just put it all in one thread. :)
Last edited by aaronsummers on Wed Jun 15, 2011 10:01 pm, edited 5 times in total.
By BlackoutV
#100436
nice write up...and if people have questions post them in here, so all of the shit discussed is in one place and easier to find.
User avatar
By Tonez
#100727
Great write up! Thanks for clearing it all up! :thumbsup:

You even got yourself a "sticky" thread!
User avatar
By Starkles
#139465
I might have to go round 2 with this. Round one ended in smoke and melted wires haha. Me and Adam kind of went into it blind and went off of the small amount of information that was available at the time.
User avatar
By Starkles
#139466
Question, actually. On the first Diagram, the green wire is for RPM signal, and in the second diagram it says that the gray wire is for RPM. But in the first diagram gray is used for Throttle signal. Any input on that?
User avatar
By aaronsummers
#139477
The Green wire from the NEO is RPM and the Gray wire from the Neo is Throttle Signal.

Pin 31 on our ECU will be a Gray wire(which is RPM on out cars) needs to be connected to the Green wire on the Neo.

The first diagram is of the NEO's wiring. The second diagram is of our cars ECU.

Sorry if it wasnt very clear in the OP. Ill watch the thread close again and try to catch any questions you may have. Ill help as much as I can. Good luck man
By SPCVZL
#227164
I have 1 question is anyone else having issue with rpm. Just did install and my rpm on neo is jumping up sporadically upon full throttle. I'm worried it will affect the tune so I'm gonna hold off on my tuning until I get this figured out.

It does not help that the new Sentra models are ov[…]

B16 Suspension Options

I have an 07 se-r spec-v and have decided to stay[…]

Multiple Related? Issues

The clunk might be from the sway bar end links in […]

You have the SR Turbo? If so, ya sucks that they'r[…]