Moderators: B17 Moderator, B16 Moderator

User avatar
By daron2003
#129310
Hey guys, I have an '08 SE-R that runs great, but it won't shift into park now. It seems like the shift lock button on the knob won't compress all the way when I try and shift it up into park. I've been just shutting it off and turning it on in neutral and using my e-brake. Any ideas what it might be?
By White Night
#129315
there shoul be a litle circle next to your shift lever that says "shift lock".stick a small flat head(or something flat and skinny) and pop open the little cover that,then stick the flat head inside until you feel like your pressing a button and hold it,then shift into park. You can do this whenever you want to shift into drive.
User avatar
By mdh
#129316
There should be a lock release somewhere. Im not very familiar with the b16 so someone go has one will have to help you but I'm sure that somewhere you'll find a lock release and it should allow you to put it in park. Check through the owners manual.
By spec_in_ser3
#129319
White Night wrote:there shoul be a litle circle next to your shift lever that says "shift lock".stick a small flat head(or something flat and skinny) and pop open the little cover that,then stick the flat head inside until you feel like your pressing a button and hold it,then shift into park. You can do this whenever you want to shift into drive.

:thumbup: this should work , i know if the car gets stuck in park this will help so i figure it should work both ways
User avatar
By daron2003
#129320
Popped the cover and pressed the shift lock button with screwdriver, then tried to shift it. Still won't shift up into park. I'm stumped. The button on the shift lever still doesn't feel like it's compressing all the way when I squeeze it when trying to shift up into park.
By White Night
#129322
daron2003 wrote:Popped the cover and pressed the shift lock button with screwdriver, then tried to shift it. Still won't shift up into park. I'm stumped. The button on the shift lever still doesn't feel like it's compressing all the way when I squeeze it when trying to shift up into park.


Wtf???..That should have worked,did you try anything else besides a flat head screwdriver? That usually works :x ....hmmmm..are you sure you are holding the screwdriver and shifting at the same time?
User avatar
By daron2003
#129324
I actually used the blunt end of some scissors to press the button and then tried shifting it up into park. Didn't work. I'm certain the button was pressed when I tried shifting it though, I felt it. I'll go get a smaller flathead and try it again when I get home from work in a few hours.

Is it even possible to engage this lock if you've never used it or messed with it before? I never did anything different, then all of the sudden on Saturday night it wouldn't shift up into park anymore...
User avatar
By Marvel_Man
#129325
Definitely try using a thin flat-head screwdriver. Usually you do this to release the car from being stuck in park to get it into drive/neutral, not the other way around. But, it should have the same effect.
User avatar
By daron2003
#129352
So I tried with a slim flathead. Still wouldn't shift into park. Think this a linkage issue? Or the tranny control module maybe?
User avatar
By Marvel_Man
#129481
Huh. That's really weird. I guess you could just try taking apart the shifter and see if the button is messed up then. That's the only other thing I can think of. If it was a problem with the transmission, then it probably wouldn't shift at all.
User avatar
By daron2003
#129615
Yeah, I got the shifter section of the service manual. I'll tear it apart this weekend. Hoping it's something minor. Wish me luck!
User avatar
By daron2003
#129643
Fixed. A small piece of the selector button (one of the tabs that keep the button in the grooves) has broken off inside the selector, making it impossible to push the button all the way down.
http://www.flickr.com/photos/48899042@N08/6474280397/in/photostream/

The broken tab was removed with needlenose. I put it back together and re-installed it. Car works like a champ now! :D

I'm still going to replace the knob ($35 at Nissan dealer) though, just because I don't want it to be unstable inside there and risk another tab breaking off...
User avatar
By Marvel_Man
#129665
Nice man. Glad you got it fixed, and especially glad it was an easy fix, lol.
By urmykol
#237558
Hey, I'm really hoping I have the same issue as you did. My car won't go into park. How did you remove the housing on the shifter to get inside there? Do you remove the strip of plastic that goes around the top of the shifter?
93 Sentra poor fuel mileage

I’ve had two b13s. Low 20s in the city is very nor[…]

Factory Service Manuals Online

Could be, saw a post from another forum that hosts[…]

Proud 2010 QR25DE owner from MKE

Hello everyone, New user here for help, info and […]

They actually look really nice. Good idea, brings[…]