2007-2012
By yogib777
#247015
eXcude wrote:Sup Allsentra, haven't posted in a while. I've been doing some work on the car, not fun stuff like upgrades. I've had an intermittent misfire issue. After replacing the spark plug and plug boot that was covered in oil I put on a new valve cover and gasket. The leaking has stopped, but the CEL codes continue randomly. Idle seems to take a nose dive randomly. Also my AC compressor is f'd causing the car to make this awful noise and just act all around strange.

I'm not feeling it right now, I see why these are are not popular, heh.

So I'm pushing forward, I am going to rip the AC out as I don't normally use it and see where to go from there. I am starting to suspect maybe an o2 sensor issue as well, that would explain some of the engine oddness.

Everyday a v6 Camry is looking better and better... :?


my engine has but 13k on it
but the chassis near 90k

I got tired of the piece by piece stuff
i restored the major chassis parts

bearings, bushings, lca's, parts of the wiring harness
brakes hoses, etc

all at once

spent 2.5k
car is like new

and i can enjoy it again
did this about 1.5 years ago

have had no maintenance probs since
and no repairs for that time period

did move battery to the rear
and added a water/meth injection system this year

like new
Image20170811_130557 by Barry Belgard, on Flickr
User avatar
By eXcude
#247028
I was just throwing a fit everyone, the Spec has no car payment so I'll be keeping it for a while.
User avatar
By jamaul08
#247029
eXcude wrote:I was just throwing a fit everyone, the Spec has no car payment so I'll be keeping it for a while.


lmao, HODL
User avatar
By eXcude
#247033
Welp when you pay a car off in 16 months you kind of hope to not have to put any money into shit falling off it within months of said payoff.

It's very frustrating. But cars are, and always will be, money pits.

//rant
User avatar
By eXcude
#247176
Brought this to my mechanic, they couldn't fix it. They validated my compression was good and concluded it's a dirty engine (carbon build-up) or something my bolt-ons are causing.

I'm not terribly happy about the prognosis, but it appears I am still on my own to figure this out.

Codes they pulled:
P0301
P0300
P0171
P0174

In my OP here I remember saying 'Never owned a Nissan'

Heh, probably never will again after this one :?
User avatar
By eXcude
#247177
Oh I also no longer have an AC compressor in this thing, I had them install the bypass pulley.
User avatar
By eXcude
#247230
you can skip to 30 seconds: https://photos.app.goo.gl/hDWthCdFgX9gWihHA

I brought it to a local garage, they say the ECU is telling my plugs to fire incorrectly. Recommended taking it to the stealership.

It was towed 20 miles away, awaiting results. They won't get to it until Friday.

Sooo yeah.
  • 1
  • 17
  • 18
  • 19
  • 20
  • 21
XCLR8/ 2010 S/ CA

Currently in the process of 3D scanning the stock […]

there is no assurance that using an OEM deck with […]

Reaquainting myself

Nah, I should stay quiet... I've already posted m[…]

I need those for some Chicago drivers.