Moderators: B17 Moderator, B16 Moderator

By raynon89
#248227
Hi all. Thanks in advance for any help on this.

I'm working on a 2012 Sentra with a blower motor not coming on.

I removed and bench tested the blower motor by hooking it up directly to a car battery. It works perfectly.

My problem/confusion:
I have voltage at the plug itself for the blower motor.
Voltage on the yellow wire is 11.8 volts constant.
Voltage on the red wire ranges from 2.8-11.8 volts depending on the position of the blower speed selector. (11.8v at the low setting. 2.8volts on the HIGH setting - yes, lower voltage with fan position on high)
Does this sound weird to anyone else? Why voltage in both wires?

Fuses are good. Relays are good.

Blower motor resistor I believe is good because there is voltage at the plug for the blower motor and because the owner said the fan quit working suddenly all together on all speeds. It did not quit working on one speed or two and then eventually none - which would indicate a bad resistor. So I'm assuming it is good for now.

I'm confused as to why there is voltage in both wires at the blower motor plug. I believe this may be my problem.

UPDATE: There is no continuity between the positive and negative terminals on the blower motor resistor. Is this a dead giveaway for a bad resistor? I'm not sure how to test it.

Thanks.
Gas Needle/Gauge

When I fill up sometimes my needle goes all the wa[…]

Gas Needle/Gauge

When I fill up sometimes my needle goes all the wa[…]

Gas Needle/Gauge

When I fill up sometimes my needle goes all the wa[…]

Gas Needle/Gauge

When I fill up sometimes my needle goes all the wa[…]