Need help with your car? Ask in here

Moderators: B17 Moderator, B16 Moderator

#177320
Break, reverse and turn signals work, taillights and license plate lights not working. Tried looking for fuse but could not locate(checked engine fuse box and to the left of the steering wheel).

Anyone know of a fix?

2012 sentra se r.
#177328
VanSentra wrote:Break, reverse and turn signals work, taillights and license plate lights not working. Tried looking for fuse but could not locate(checked engine fuse box and to the left of the steering wheel).

Anyone know of a fix?

2012 sentra se r.



were you doing something to your car to maybe cause a fuse to blow? i had to go to my fuse panel in the engine bay to find my horn fuse. all the fuses are labelled. its under the intake snorkel right behind the drivers headlight. if you have spare fuses try swapping them out with the ones in the car. sometimes u cant tell that the fuse is blown just by looking at it. the horn fuse i blew didnt look blown but it was.
#177334
here you go. its actually the larger box in front of the strut tower. there are tabs all the way around it. pull up on the top as you use a flat tip to pop each tap. pull it up and to the fender to pull out. then carefully turn it over. you will now see the fuses and labels. who ever came up with this design should be shot Image

Image
Image
Image
Image
#178110
Wait...have you not tested the bulbs? If you have changed them.....and the still don't light and aren't getting blown...get a VM and test your grounds etc.
#236878
hi guys, sorry for bumping this thread. i have the same issue, checked both fuse and the bulb, they were fine. what else should I do? I am suspecting the wire at the moment. wondering how much would that cost me at the parts dept
#248182

goldenboyrb wrote:
hi guys, sorry for bumping this thread. i have the same issue, checked both fuse and the bulb, they were fine. what else should I do? I am suspecting the wire at the moment. wondering how much would that cost me to write my paper with experts at the parts dept


Tail lights, brake lights, license plates light and parking lights are not working... Any ideas? I also tried a hard reset of TIPM (just like the guys suggested on 2carpros forum). But in vain..
P.S.: Sorry for this bump.

yes i am finding luck with body mods . Showbox […]

My business Page

Every business owner must be using the Search Engi[…]

2010 Sentra issue

I have a 2010 Nissan Sentra and it was having a cr[…]

Are the items still for sale? I think the OP is l[…]